you need swig at least 1.3.14
[mikachu/openbox.git] / README.CVS
1 To build Openbox from CVS you need:
2
3 A C++ Compiler (GNU GCC/G++ 3.2+ suggested)
4 GNU Gettext 0.11.5
5 GNU Autoconf 2.50+
6 GNU Automake 1.7.1+ (1.7.1 has a bug fix for py-compile)
7 GNU Libtool
8 Xft2 library/headers (devel package) (http://www.fontconfig.org)
9 Xlib library/headers (devel package)
10 Python library/headers (devel package) (http://www.python.org)
11 SWIG 1.3.14+ (http://www.swig.org)
12
13 I recommend the latest version of all these packages.
14
15 Do the following to build and install Openbox in CVS:
16
17 % ./bootstrap
18 % ./configure
19 % make all install
20
21 When building the SWIG generated wrappers (*_wrap.cc), a huge number of
22 compiler warnings will be generated. Don't be phased by this, it doesn't mean
23 anything is broken unless you get an actual error.
24
25 Don't try running it from the src/ directory without installing, it won't work.
26 It needs to be installed before it is run.
27
28 The installed binary is 'openbox3'.
29
30
31
32 ----
33 Here's the packages from Debian (sid):
34   g++
35   gettext
36   automake1.7
37   autoconf
38   libtool
39   libxft2-dev
40   python-dev
41   swig1.3
42
43
44 ----
45 Check out the Wiki for how to configure Openbox 3:
46 http://icculus.org/openbox/phpwiki/index.php/PythonScripting