mention that 2.9x is not supported
[dana/openbox.git] / README.CVS
1 To build Openbox from CVS you need:
2
3 A C++ Compiler (GNU GCC/G++ 3.2+ suggested, 2.9x is not supported as it is not
4                 very compliant with the ISO C++ standards)
5 GNU Gettext 0.11.5
6 GNU Autoconf 2.50+
7 GNU Automake 1.7.1+ (1.7.1 has a bug fix for py-compile)
8 GNU Libtool
9 Xft2 library/headers (devel package) (http://www.fontconfig.org)
10 Xlib library/headers (devel package)
11 Python library/headers (devel package) (http://www.python.org)
12 SWIG 1.3.14+ (http://www.swig.org)
13
14 I recommend the latest version of all these packages.
15
16 Do the following to build and install Openbox in CVS:
17
18 % ./bootstrap
19 % ./configure
20 % make all install
21
22 When building the SWIG generated wrappers (*_wrap.cc), a huge number of
23 compiler warnings will be generated. Don't be phased by this, it doesn't mean
24 anything is broken unless you get an actual error.
25
26 Don't try running it from the src/ directory without installing, it won't work.
27 It needs to be installed before it is run.
28
29 The installed binary is 'openbox3'.
30
31
32
33 ----
34 Here's the packages from Debian (sid):
35   g++
36   gettext
37   automake1.7
38   autoconf
39   libtool
40   libxft2-dev
41   python-dev
42   swig1.3
43
44
45 ----
46 Check out the Wiki for how to configure Openbox 3:
47 http://icculus.org/openbox/phpwiki/index.php/PythonScripting