once is enough
[duncan/yast2-qt4.git] / yast2-qt4.spec.in
1 @HEADER-COMMENT@
2
3
4 @HEADER@
5 BuildRequires:  dbus-1-devel boost-devel libzypp-devel curl-devel docbook-xsl-stylesheets doxygen libdrm-devel libjpeg-devel libxcrypt-devel libxslt perl-XML-Writer libqt4-devel rpm-devel sgml-skel update-desktop-files yast2-devtools yast2-core-devel hal-devel
6
7 Summary:        -
8 BuildRequires: yast2-core-devel >= 2.16.10
9 Requires:      yast2-core >= 2.16.10
10 Requires:       libzypp >= 3.11.8
11 Provides:       yast2_ui
12 Provides:       y2base:/usr/lib/YaST2/servers/qt
13 Provides:       y2base:/usr/lib/YaST2/plugin/libpy2qt.so.2
14 Provides:       yast2-ui-qt yast2-ui-qt-devel
15 Obsoletes:      yast2-ui-qt yast2-ui-qt-devel
16 Provides:       y2qt
17 Obsoletes:      y2qt
18
19 %description
20 -
21
22 @PREP@
23
24 @BUILD-QT@
25
26 @INSTALL@
27 rm -f $RPM_BUILD_ROOT/@plugindir@/libpy2qt4.la
28 rm -f $RPM_BUILD_ROOT/@plugindir@/libpy2qt4_pkg.la
29
30
31 @CLEAN@
32
33 %if 0%{?suse_version} <= 1010
34 %define _xorg7fonts /usr/X11R6/lib/X11/fonts
35 %else
36 %define _xorg7fonts /usr/share/fonts
37 %endif
38
39 %files
40 %defattr (-, root, root)
41 @plugindir@/libpy2qt4.so.*
42 @plugindir@/libpy2qt4.so
43 @plugindir@/libpy2qt4_pkg.so.*
44 @plugindir@/libpy2qt4_pkg.so
45 @imagedir@
46 %dir %{_xorg7fonts}/uni
47 %verify(not md5 size mtime) %{_xorg7fonts}/uni/fonts.dir
48 %{_xorg7fonts}/uni/newunifont.pcf.gz
49 %{_xorg7fonts}/uni/unifont.pcf.gz
50 %dir @ydatadir@
51 @ydatadir@/lang_fonts
52 %doc @docdir@