merging mod-ui changes from trunk
[duncan/yast2-qt4.git] / yast2-qt4.spec.in
1 @HEADER-COMMENT@
2
3
4 @HEADER@
5 BuildRequires:  dbus-1-devel boost-devel libzypp-devel curl-devel docbook-xsl-stylesheets doxygen libdrm-devel libjpeg-devel libxcrypt-devel libxslt perl-XML-Writer libqt4-devel rpm-devel sgml-skel update-desktop-files yast2-devtools yast2-core-devel hal-devel
6
7 Summary:        -
8 BuildRequires: yast2-core-devel >= 2.16.10
9 Requires:      yast2-core >= 2.16.10
10 Requires:       libzypp >= 3.11.8
11 Provides:       yast2_ui
12 Provides:       y2base:/var/lib/YaST2/servers/qt
13 Provides:       y2base:/usr/lib/YaST2/servers/qt
14 Provides:       y2base:/usr/lib/YaST2/plugin/libpy2qt.so.2
15 Provides:       yast2-ui-qt yast2-ui-qt-devel
16 Obsoletes:      yast2-ui-qt yast2-ui-qt-devel
17 Provides:       y2qt
18 Obsoletes:      y2qt
19
20 %description
21 -
22
23 @PREP@
24
25 @BUILD-QT@
26
27 @INSTALL@
28 rm -f $RPM_BUILD_ROOT/@plugindir@/libpy2qt4.la
29 rm -f $RPM_BUILD_ROOT/@plugindir@/libpy2qt4_pkg.la
30
31
32 @CLEAN@
33
34 %if 0%{?suse_version} <= 1010
35 %define _xorg7fonts /usr/X11R6/lib/X11/fonts
36 %else
37 %define _xorg7fonts /usr/share/fonts
38 %endif
39
40 %files
41 %defattr (-, root, root)
42 @plugindir@/libpy2qt4.so.*
43 @plugindir@/libpy2qt4.so
44 @plugindir@/libpy2qt4_pkg.so.*
45 @plugindir@/libpy2qt4_pkg.so
46 @imagedir@
47 %dir %{_xorg7fonts}/uni
48 %verify(not md5 size mtime) %{_xorg7fonts}/uni/fonts.dir
49 %{_xorg7fonts}/uni/newunifont.pcf.gz
50 %{_xorg7fonts}/uni/unifont.pcf.gz
51 %dir @ydatadir@
52 @ydatadir@/lang_fonts
53 %doc @docdir@